Upgraded to 2.7 -- "Could not find nokogiri-1.12.5 in any of the sources"

I’ve been on Jets 3.0.17 for a week or so, but today decided to complete my upgrade and move things to the Ruby 2.7 runtime.

My Gemfile.lock contains:

nokogiri (1.12.5-x86_64-darwin)
      racc (~> 1.4)

And locally I’m using Ruby 2.7.0. Deploy works fine, but my function spits out:

    "errorMessage": "Could not find nokogiri-1.12.5 in any of the sources",
    "errorType": "Init<Bundler::GemNotFound>",
    "stackTrace": [
        "/var/runtime/gems/bundler-2.2.27/lib/bundler/definition.rb:496:in `materialize'",
        "/var/runtime/gems/bundler-2.2.27/lib/bundler/definition.rb:234:in `specs_for'",
        "/var/runtime/gems/bundler-2.2.27/lib/bundler/runtime.rb:18:in `setup'",
        "/var/runtime/gems/bundler-2.2.27/lib/bundler.rb:149:in `setup'",
        "/var/runtime/gems/bundler-2.2.27/lib/bundler/setup.rb:20:in `block in <top (required)>'",
        "/var/runtime/gems/bundler-2.2.27/lib/bundler/ui/shell.rb:136:in `with_level'",
        "/var/runtime/gems/bundler-2.2.27/lib/bundler/ui/shell.rb:88:in `silence'",
        "/var/runtime/gems/bundler-2.2.27/lib/bundler/setup.rb:20:in `<top (required)>'",
        "/var/lang/lib/ruby/site_ruby/2.7.0/rubygems/core_ext/kernel_require.rb:85:in `require'",
        "/var/lang/lib/ruby/site_ruby/2.7.0/rubygems/core_ext/kernel_require.rb:85:in `require'",
        "/var/task/handlers/jobs/upload_job.rb:1:in `<top (required)>'",
        "/var/lang/lib/ruby/site_ruby/2.7.0/rubygems/core_ext/kernel_require.rb:85:in `require'",
        "/var/lang/lib/ruby/site_ruby/2.7.0/rubygems/core_ext/kernel_require.rb:85:in `require'"

I have tried clearing /tmp/jets, deleting my lockfile and re-bundling, etc. to no avail. Any ideas?

It looks like this shouldn’t be happening anymore based on Issue with native gems from darwin and similar issues, but I’m on the latest Jets, so I’m not sure what’s up exactly.

I believe I’ve fixed this by making sure my Bundler version is 2.2.27 to match Amazon’s. I was on 2.2.28… is it documented anywhere that these much match exactly?

I lied. It worked once but after redeploying (using Ruby 2.7.0 and Bundler 2.2.27), it’s happening again. No clue

Unsure what’s going on here. Just deployed

Which spits out the nokogiri version for testing purposes. Here’s a screenshot since deploy jets app deployed at


will be destroyed in the future.


Screen Shot 2021-10-07 at 2.50.21 PM

Wondering if you can deploy the jets-nokogiri-demo app and see what happens.