Config.gems.disable = true not working

On Jets 3.0.11, with config.gems.disable = true set in config/application.rb and passing in a custom lambda layer via config.lambda.layers in config/environments/[environment].rb I am able to utilize my custom layer, however, Jets is still trying to publish it’s own GemLayer.

I thought that may have fixed this, but a Jets GemLayer is still attempting to be published. I have only allowed the Jets deploy role the ability to upload our custom Gem layer and jets deploy via CI is failing with access denied because it is attempting to publish the generated Jets GemLayer.

How do we truly disable the autogenerated Jets GemLayer?