Error initializating project

I have a terraspace project that works correctly in Linux, I’m trying to make it work on docker in a windows machine.
I run the Package terraspace · GitHub image sharing the project folder as a volume.
When I go in the prejct folder and run bundle update it gives me the following error

An error occurred while installing bigdecimal (3.1.7), and Bundler cannot continue.

In Gemfile:
  terraspace_plugin_aws was resolved to 0.5.1, which depends on
    s3-secure was resolved to 0.6.1, which depends on
      cli-format was resolved to 0.6.0, which depends on
        activesupport was resolved to, which depends on

The Gemfile config is

Does someone has an idea on how to fix it ?

Thanks !

:face_with_monocle: Tried to reproduce with


source ""

gem "terraspace", "~> 2"
gem "terraspace_plugin_aws"
gem "rspec-terraspace"
gem "tilt", "~> 2.1.0"

Bundler was able to resolve the dependencies when tested.

❯ bundle
Bundle complete! 4 Gemfile dependencies, 55 gems now installed.
Use `bundle info [gemname]` to see where a bundled gem is installed.

❯ for i in terraspace terraspace_plugin_aws rspec-terraspace tilt ; do echo $i ; bundle info $i --path ; done

❯ bundle check
The Gemfile's dependencies are satisfied


Wondering if you can try blowing away the Gemfile.lock. Sometimes Gemfile.lock has dependencies in a way that won’t allow bundler to resolve the gem dependencies graph. Blowing it away sometimes fixes it.

rm -f Gemfile.lock