Struggling With Output Helper


Congratulations for awesome framework.

I Have To two stacks : Infra and Notifications.

I want use outputs from infra in notifications stack:

My base.tfvars file in notifications is the following:

dynamodb_stream_arn = <%= output('infra.dynamo_db_stream_arn') %>

I know the dynamo_db_stream_arn output in infra stack exists and it’s deployed. The value is returned when i ran terraspace output infra.

But when i ran terraspace up notifications get the following error:

Output dynamo_db_stream_arn was not found for the notifications tfvars file. Either infra stack has not been deployed yet or it does not have this output: dynamo_db_stream_arn. Also, if local backend is being used and has been removed/cleaned, then it will also result zero-byte state.json with the ‘terraform state pull’ used to download the terraform state and output will not be found.)

I think my problem is related with: Tfstate.json in /tmp is empty sometimes but i’m unable to fix it.

I’m using terraspace 2.1.6 version

Someone could help me debug this?

Fábio Santos

Solve. With version upgrade

1 Like