Sudden BasePathFunction failures in two separate AWS accounts

I’m wondering if something in AWS API Gateway has changed. I have two separate AWS accounts - one for staging and one for production. I’m still on Jets 3 because of upgrade difficulties.

In staging, I’ve been experimenting with the Dynamoid (DynamoDB) gem and that was working fine - then a couple of days ago, I deployed again without only a small bug fix - no gem changes, ruby version changes, Jets version changes, etc. and suddenly got this error:

10:16:27AM CREATE_FAILED AWS::CloudFormation::Stack ApiDeployment20240211101255 Embedded stack arn:aws:cloudformation:us-east-1:939853430143:stack/er-serverless-prod-ApiDeployment20240211101255-<> was not successfully created: The following resource(s) failed to create: [BasePathFunction].

I tried investigating and could not come up with any solution to fix it. The last time I got this error was when I tried to upgrade to Jets 4. So, I just locked down on Jets 3 for the time being and waited for Jets 5.

This morning in production, I made a security fix. The master branch has ZERO changes other than a small code security fix. And, I got the same BasePathFunction error again, which now leads me to believe that AWS has changed something to be incompatible with Jets and custom domains.

Is there any kind of reset that I can run to get this to succeed? I need to get some new functionality out now.

theron W.